ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 让普通网管都能使用思科路由器(转)

让普通网管都能使用思科路由器(转)

原创 Linux操作系统 作者:jcszjswkzhou 时间:2019-03-13 08:00:09 0 删除 编辑
看到一些网管吗由于很少使用到思科路由器。

万一到别处应聘时被考到这个问题就郁闷了。

所以特别把我以前的思科代码放出。

大家只要进入思科后按步骤一步步打出再重起就可以使用思科了。

----------------------------------------------------------------------------------------------------


router> //这是进入思科的开始了!不要说不会开终端
router>en //进入特权模式
router# conf t //进入高级设置

router(config)# hostname public //定义路由器主机名为PUBLIC
public(config)# enable secret noriko //设路由超级管理密码
public(config)# interface fastethernet0/0 //进入外网网卡设定

public(config-if)# ip address 218.80.225.198 255.255.255.252 //添加外网IP.偶上海以前网吧IP,不要攻击哦.
public(config-if)# ip access-group 100 in //定义访问规则号
public(config-if)# ip nat outside //定义这个fastethernet0/0 是外网网卡
public(config-if)# duplex auto //单,双工模式
public(config-if)# speed auto //速度auto
public(config-if)# no shutdown //激活外网端口
public(config-if)# exit //EXIT

public(config)# interface fastethernet0/1 //同上,不过是另一个端口

public(config-if)# ip address 10.128.132.254 255.255.255.0 //同上
public(config-if)# ip access-group 101 in //同上
public(config-if)# ip nat inside //同上
public(config-if)# duplex auto //同上
public(config-if)# speed auto //同上
public(config-if)# no shutdown //同上
public(config-if)# exit //同上

public(config)# ip nat pool public 218.80.225.198 218.80.225.198 netmask 255.255.255.252 //该命令定义访问控制列表与终端NAT地址池之间的映射
public(config)# ip nat inside source list 1 pool public overload //NAT了
public(config)# ip route 0.0.0.0 0.0.0.0 218.80.225.197 //定义路由表
public(config)# ip nameserver 202.96.199.133 //这加不加没关系的
public(config)# ip nameserver 202.96.209.5 //这加不加没关系的

public(config)# access-list 1 permit 10.128.132.0 0.0.0.255
public(config)# access-list 100 deny icmp any any
public(config)# access-list 100 permit ip any any
public(config)# access-list 101 deny tcp any any eq 135
public(config)# access-list 101 deny tcp any any eq 136
public(config)# access-list 101 deny tcp any any eq 137
public(config)# access-list 101 deny tcp any any eq 138
public(config)# access-list 101 deny tcp any any eq 139
public(config)# access-list 101 deny tcp any any eq 445
public(config)# access-list 101 permit ip any any

//控制列表偶就不说了.因为我的不全.大家可去NET130看看另的大哥们做的

public(config)# line con 0
public(config-line)# password noriko
public(config-line)# login
public(config-line)# line aux 0
public(config-line)# line vty 0 4
public(config-line)# password noriko
public(config-line)# login
public(config-line)# end

//这上面是定义TELNET等密码..和最上面可一样.
public# copy run start //把配置转入到FLASH闪存中保存
public# reload //重起


-------------------------------------------------------------------------------------------------

按上面做下去就OVER了。


来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/10294527/viewspace-124020/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2007-08-29

  • 博文量
    2720
  • 访问量
    1985508